Commit 5bb85033 authored by Dmitry Romanov's avatar Dmitry Romanov
Browse files

Update gatsby to 4.8.1, fix theme and configs

parent 003a1203
Pipeline #28517 passed with stage
in 3 minutes and 49 seconds
......@@ -34,13 +34,16 @@ module.exports = {
icon : `static/favicon.png`,
},
},
`gatsby-plugin-sitemap`,
{
resolve : `gatsby-plugin-google-analytics`,
options : {
// trackingId: ``,
},
},
`gatsby-plugin-sitemap`,
// In order to use google-analytics one needs to provide trackingId
// commented out until trackingId is provided
// {
// resolve : `gatsby-plugin-google-analytics`,
// options : {
// // trackingId: ``,
// },
// },
{
resolve : `gatsby-plugin-canonical-urls`,
options : {
......
{
"name": "gatsby-starter-rocket-docs",
"name": "eic-tutorials",
"private": true,
"version": "1.0.0",
"version": "3.0.0",
"description": "Out of the box Gatsby Starter for creating documentation websites easily and quickly. With support for MDX, code highlight, Analytics, SEO and more",
"author": "João Pedro Schmitz <oi@joaopedro.cc> (@joaopedro_cc)",
"license": "MIT",
"starter-name": "gatsby-starter-rocket-docs",
"dependencies": {
"@rocketseat/gatsby-theme-docs": "^2.1.0",
"gatsby": "^2.19.10",
"gatsby-plugin-canonical-urls": "^2.1.19",
"gatsby-plugin-google-analytics": "^2.1.34",
"gatsby-plugin-manifest": "^2.2.37",
"gatsby-plugin-offline": "^3.0.32",
"gatsby-plugin-sitemap": "^2.2.26",
"prop-types": "^15.7.2",
"react": "^16.12.0",
"react-dom": "^16.12.0"
"gatsby": "^4.8.1",
"@rocketseat/gatsby-theme-docs": "^3.1.0",
"gatsby-plugin-canonical-urls": "^4.8.0",
"gatsby-plugin-google-analytics": "^4.8.0",
"gatsby-plugin-manifest": "^4.8.1",
"gatsby-plugin-offline": "^5.8.1",
"gatsby-plugin-sitemap": "^5.8.0",
"emotion-theming": "10.3.0",
"@emotion/core":"10.1.1",
"prop-types": "^15.8.1",
"react": "^17.0.2",
"react-dom": "^17.0.2",
"react-dev-utils":"^12.0.0",
"immer":"9.0.12"
},
"devDependencies": {},
"keywords": [
......
......@@ -2,9 +2,25 @@ import React from 'react';
import { Global, css } from '@emotion/core';
import { useTheme } from 'emotion-theming';
import { lighten } from 'polished';
import { theme } from './theme';
export default function GlobalStyle() {
const theme = useTheme();
const theme = {
colors: {
primary: '#E1A809',
background: '#fff',
sidebar: {
background: '#ffffff',
link: '#737373',
heading: '#aaa',
linkActive: '#13131A',
itemActive: '#F5F5FA',
footer: '#A8A8B3',
}
}
};
console.log(theme);
return (
<Global
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment