New version, which requires acts@15.1 or higher.